本站已运行

攻城狮论坛

xinmeng

作者: 非常CCNA
查看: 1246|回复: 12

主题标签Tag

more +今日重磅推荐Recommend No.1

所有IT类厂商认证考试题库下载所有IT类厂商认证考试题库下载

more +随机图赏Gallery

重量级~~30多套JAVA就业班全套 视频教程(请尽快下载,链接失效后不补)重量级~~30多套JAVA就业班全套 视频教程(请尽快下载,链接失效后不补)
【超过几百G】EVE 国内和国外镜像 全有了 百度群分享【超过几百G】EVE 国内和国外镜像 全有了 百度群分享
某linux大佬,积累多年的电子书(约300本)某linux大佬,积累多年的电子书(约300本)
乾颐堂现任明教教主Python完整版乾颐堂现任明教教主Python完整版
乾颐堂 教主技术进化论 2018-2019年 最新31-50期合集视频(各种最新技术杂谈视频)乾颐堂 教主技术进化论 2018-2019年 最新31-50期合集视频(各种最新技术杂谈视频)
Python学习视频 0起点视频 入门到项目实战篇 Python3.5.2视频教程 共847集 能学102天Python学习视频 0起点视频 入门到项目实战篇 Python3.5.2视频教程 共847集 能学102天
约21套Python视频合集 核心基础视频教程(共310G,已压缩)约21套Python视频合集 核心基础视频教程(共310G,已压缩)
最新20180811录制 IT爱好者-清风羽毛 - 网络安全IPSec VPN实验指南视频教程最新20180811录制 IT爱好者-清风羽毛 - 网络安全IPSec VPN实验指南视频教程
最新20180807录制EVE开机自启动虚拟路由器并桥接物理网卡充当思科路由器最新20180807录制EVE开机自启动虚拟路由器并桥接物理网卡充当思科路由器
最新2018/07/29录制 IT爱好者清风羽毛-Cisco IOS ZBF防火墙视频最新2018/07/29录制 IT爱好者清风羽毛-Cisco IOS ZBF防火墙视频
乾颐堂 教主技术进化论 2018年 最新1-30期合集视频(各种最新技术杂谈视频)乾颐堂 教主技术进化论 2018年 最新1-30期合集视频(各种最新技术杂谈视频)
Cisco CCW售前销售报价系统使用方法Cisco commerce workspaceCisco CCW售前销售报价系统使用方法Cisco commerce workspace

中小型企业网络设计

  [复制链接]
非常CCNA [VIP@钻石] 发表于 2013-5-26 16:30:45 | 显示全部楼层 |阅读模式
查看: 1246|回复: 12
开通VIP 免金币+免回帖+批量下载+无广告

一、设计需求:

1)经理室、设备科、人事处,可以访问外部网络,外部网络不能访问经理室、设备科、人事处,财务部不允许访问外部网络。

2)经理室可以访问设备科,财务部,人事处。

3)人事处和设备科可以互访,但人事处和设备科与财务部不能互访。

4)通过帧中继,实现云两端的路由能够通信。

二、网络拓扑

中小型企业网络设计 - 攻城狮论坛 - 223925471.png

3.根据拓扑图和实验需求,我们分析一下整体的网络,首先要在二层交换机上配置vlan,并且把相应的端口加入,而在三层交换机上配置vlan间路由,在R1和三层交换机上配置一个路由协议EIGRP,需要注意的是R1上的s1/0端口不行宣告进动态路由协议,我们需要配置一条默认路由指向外网,我们需要实现经理室、设备科、人事处,可以访问外部网络,外部网络不能访问经理室、设备科、人事处,财务部不允许访问外部网络。就需要在R1上配置PAT,以实现需求,

要实现经理室可以访问设备科,财务部,人事处,人事处和设备科可以互访,但人事处和设备科与财务部不能互访。可以在三层交换机上配置ACL,并且在vlan中应用,并且要注意ACL的应用方向,最后就是配置一个帧中继网络了。

4.现在我们分析完整个网络就开始配置了

SW1:

Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)#vlan 30

Switch(config-vlan)#ex

Switch(config)#int f0/1

Switch(config-if)#sw

Switch(config-if)#switchport a

Switch(config-if)#switchport access v

Switch(config-if)#switchport access vlan 10

Switch(config-if)#int f0/2

Switch(config-if)#sw

Switch(config-if)#switchport a

Switch(config-if)#switchport access v

Switch(config-if)#switchport access vlan 20

Switch(config-if)#int f0/3

Switch(config-if)#sw

Switch(config-if)#switchport a

Switch(config-if)#switchport access v

Switch(config-if)#switchport access vlan 30

Switch(config-if)#int f0/10

Switch(config-if)#sw

Switch(config-if)#switchport m

Switch(config-if)#switchport mode t

Switch(config-if)#switchport mode trunk


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to down


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/10, changed state to up


Switch(config-if)#int f0/15

Switch(config-if)#sw

Switch(config-if)#switchport m

Switch(config-if)#switchport mode t

Switch(config-if)#switchport mode trunk

SW2:

Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)#vlan 30

Switch(config-vlan)#int f0/4

Switch(config-if)#sw

Switch(config-if)#switchport a

Switch(config-if)#switchport access v

Switch(config-if)#switchport access vlan 10

Switch(config-if)#int f0/5

Switch(config-if)#sw

Switch(config-if)#switchport a

Switch(config-if)#switchport access v

Switch(config-if)#switchport access vlan 20

Switch(config-if)#int f0/6

Switch(config-if)#sw

Switch(config-if)#switchport a

Switch(config-if)#switchport access v

Switch(config-if)#switchport access vlan 30

Switch(config-if)#int f0/10

Switch(config-if)#sw

Switch(config-if)#switchport m

Switch(config-if)#switchport mode t

Switch(config-if)#switchport mode trunk

Switch(config-if)#int f0/20

Switch(config-if)#sw

Switch(config-if)#switchport m

Switch(config-if)#switchport mode t

Switch(config-if)#switchport mode trunk


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/20, changed state to down


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/20, changed state to up

注意交换机之间的接口需要设置为trunk

5.在各路由接口,三层交换端口和SVI接口配置相应的ip地址

SW3

Switch(config)#vlan 10

Switch(config-vlan)#vlan 20

Switch(config-vlan)#vlan 30

Switch(config-vlan)#e

Switch(config)#int vlan 10


%LINK-5-CHANGED: Interface Vlan10, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up

Switch(config-if)#ip ad

Switch(config-if)#ip address 10.10.10.254 255.255.255.0

Switch(config-if)#no shut

Switch(config-if)#int vlan 20


%LINK-5-CHANGED: Interface Vlan20, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

Switch(config-if)#ip ad

Switch(config-if)#ip address 20.20.20.254 255.255.255.0

Switch(config-if)#no shut

Switch(config-if)#int vlan 30


%LINK-5-CHANGED: Interface Vlan30, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up

Switch(config-if)#ip ad

Switch(config-if)#ip address 30.30.30.254 255.255.255.0

Switch(config-if)#no shut

Switch(config-if)#int f0/1

Switch(config-if)#no sw

Switch(config-if)#no switchport

Switch(config-if)#ip ad

Switch(config-if)#ip address 10.10.0.254 255.255.255.0

Switch(config-if)#no shut

Switch(config-if)#ex

Switch(config)#ip ro

Switch(config)#ip rout

Switch(config)#ip routi

Switch(config)#ip routing

R1:

Router(config)#int f0/1

Router(config-if)#ip ad

Router(config-if)#ip address 10.10.0.1 255.255.255.0

Router(config-if)#no shut


%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up


Router(config-if)#int f0/0

Router(config-if)#ip ad

Router(config-if)#ip address 10.0.0.1 255.255.255.0

Router(config-if)#no shut


%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


Router(config-if)#int s1/0

Router(config-if)#ip ad

Router(config-if)#ip address 11.1.1.2 255.255.255.0

Router(config-if)#no shut


%LINK-5-CHANGED: Interface Serial1/0, changed state to down

Router(config-if)#cla

Router(config-if)#cl

Router(config-if)#clock r

Router(config-if)#clock rate 64000

R2:

Router(config)#int s1/1

Router(config-if)#ip ad

Router(config-if)#ip address 11.1.1.1 255.255.255.0

Router(config-if)#no shut


%LINK-5-CHANGED: Interface Serial1/1, changed state to up


Router(config-if)#int s1/0

Router(config-if)#ip a

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/1, changed state to up

d

Router(config-if)#ip address 12.1.1.1 255.255.255.0

Router(config-if)#no shut


Router(config-if)#

%LINK-5-CHANGED: Interface Serial1/0, changed state to up

R3:

Router(config)#int s1/1

Router(config-if)#ipa d

Router(config-if)#ipad

Router(config-if)#ipaddress 12.1.1.2 255.255.255.0

Router(config-if)#no shut

注意三层交换机上要打开路由端口才可以配置ip地址还有要开启三层交换机的路由功能,还有就是PC的ip就要自己去配置了,这里就不讲了。

6.现在在R1和三层交换机上配置EIGRP协议,以便让内网互通

SW3:

Switch(config)#router eigrp 100

Switch(config-router)#net

Switch(config-router)#network 10.10.10.0 0.0.0.255

Switch(config-router)#network 20.20.20.0 0.0.0.255

Switch(config-router)#network 30.30.30.0 0.0.0.255

Switch(config-router)#network 10.10.0.0 0.0.0.255

R1:

Router(config)#router eigrp 100

Router(config-router)#net

Router(config-router)#network 10.0.0.0 0.0.0.255

Router(config-router)#network 10.10.0.0 0.0.0.255

Router(config-router)#

%DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.10.0.254 (FastEthernet0/1) is up: new adjacency

现在我们来测试一下内网是否可以互达

现在我们用设备科的pc1分别ping人事处财务部经理室

PC>ping 30.30.30.2


Pinging 30.30.30.2 with 32 bytes of data:


Reply from 30.30.30.2: bytes=32 time=11ms TTL=127

Reply from 30.30.30.2: bytes=32 time=17ms TTL=127

Reply from 30.30.30.2: bytes=32 time=17ms TTL=127

Reply from 30.30.30.2: bytes=32 time=9ms TTL=127


Ping statistics for 30.30.30.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 9ms, Maximum = 17ms, Average = 13ms


PC>ping 20.20.20.2


Pinging 20.20.20.2 with 32 bytes of data:


Reply from 20.20.20.2: bytes=32 time=8ms TTL=127

Reply from 20.20.20.2: bytes=32 time=13ms TTL=127

Reply from 20.20.20.2: bytes=32 time=16ms TTL=127

Reply from 20.20.20.2: bytes=32 time=14ms TTL=127


Ping statistics for 20.20.20.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 8ms, Maximum = 16ms, Average = 12ms


PC>ping 10.0.0.2


Pinging 10.0.0.2 with 32 bytes of data:


Reply from 10.0.0.2: bytes=32 time=12ms TTL=126

Reply from 10.0.0.2: bytes=32 time=13ms TTL=126

Reply from 10.0.0.2: bytes=32 time=10ms TTL=126

Reply from 10.0.0.2: bytes=32 time=14ms TTL=126


Ping statistics for 10.0.0.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 10ms, Maximum = 14ms, Average = 12ms

显然内网全网可达,

再ping一下外网地址

PC>ping 11.1.1.1


Pinging 11.1.1.1 with 32 bytes of data:


Request timed out.

Request timed out.

Request timed out.

Request timed out.


Ping statistics for 11.1.1.1:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

显然不通

但是我们需要实现经理室、设备科、人事处,可以访问外部网络,外部网络不能访问经理室、设备科、人事处,财务部不允许访问外部网络。就需要在R1上配置PAT,以实现需求,

要实现经理室可以访问设备科,财务部,人事处,人事处和设备科可以互访,但人事处和设备科与财务部不能互访。可以在三层交换机上配置ACL,并且在vlan中应用,并且要注意ACL的应用方向现在开始配置

7.就需要在R1上配置PAT,三层交换机上配置ACL

R1:

Router(config)#int f0/0

Router(config-if)#ip na

Router(config-if)#ip nat i

Router(config-if)#ip nat inside

Router(config-if)#int f0/1

Router(config-if)#ip na

Router(config-if)#ip nat i

Router(config-if)#ip nat inside

Router(config-if)#int s1/0

Router(config-if)#ip na

Router(config-if)#ip nat o

Router(config-if)#ip nat outside

Router(config-if)#ex

Router(config)#ac

Router(config)#access-list 1 d

Router(config)#access-list 1 deny 20.20.20.0 0.0.0.255

Router(config)#ac

Router(config)#access-list 1 p

Router(config)#access-list 1 permit a

Router(config)#access-list 1 permit any

Router(config)#ip rou

Router(config)#ip route 0.0.0.0 0.0.0.0 11.1.1.1

Router(config)#rou

Router(config)#router e

Router(config)#router eigrp 100

Router(config-router)#re

Router(config-router)#redistribute s

Router(config-router)#redistribute static

SW3:

Switch(config)#access-list 100 permit icmp 20.20.20.0 0.0.0.255 10.0.0.0 0.0.0.255

Switch(config)#int vlan 20

Switch(config-if)#ip a

Switch(config-if)#ip-

Switch(config-if)#ip ac

Switch(config-if)#ip access-group 100 in

Switch(config-if)#

配置完成后,再ping一下外网

PC>ping 11.1.1.1


Pinging 11.1.1.1 with 32 bytes of data:


Reply from 11.1.1.1: bytes=32 time=88ms TTL=253

Reply from 11.1.1.1: bytes=32 time=15ms TTL=253

Reply from 11.1.1.1: bytes=32 time=21ms TTL=253

Reply from 11.1.1.1: bytes=32 time=19ms TTL=253


Ping statistics for 11.1.1.1:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 15ms, Maximum = 88ms, Average = 35ms


显然可以了

最后只差一个帧中继的网络了

8.配置帧中继网络

R2:

Router(config)#int s1/0

Router(config-if)#en

Router(config-if)#encapsulation

Router(config-if)#encapsulation f

Router(config-if)#encapsulation frame-relay

Router(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up


Router(config-if)#f

Router(config-if)#fr

Router(config-if)#frame-relay i

Router(config-if)#frame-relay interface-dlci 203

Router(config-if)#

R3:

Router(config)#int s1/1

Router(config-if)#en

Router(config-if)#encapsulation f

Router(config-if)#encapsulation frame-relay

Router(config-if)#f

Router(config-if)#fr

Router(config-if)#frame-relay i

Router(config-if)#frame-relay interface-dlci 302

Cloud0:

中小型企业网络设计 - 攻城狮论坛 - 222510877.jpg


好了我们这样子就已经做完全部的配置了,现在我们来测试实验需求

测试设备科可不可以和财务部互访

PC>ping 20.20.20.2


Pinging 20.20.20.2 with 32 bytes of data:


Request timed out.

Request timed out.

Request timed out.

Request timed out.


Ping statistics for 20.20.20.2:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

显然不可以

9.测试财务部可不可以和经理室互访

PC>ping 10.0.0.2


Pinging 10.0.0.2 with 32 bytes of data:


Reply from 10.0.0.2: bytes=32 time=15ms TTL=126

Reply from 10.0.0.2: bytes=32 time=14ms TTL=126

Reply from 10.0.0.2: bytes=32 time=18ms TTL=126

Reply from 10.0.0.2: bytes=32 time=18ms TTL=126


Ping statistics for 10.0.0.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 14ms, Maximum = 18ms, Average = 16ms

显然可以

3.测试财务部可不可以访问外网

PC>ping 11.1.1.1


Pinging 11.1.1.1 with 32 bytes of data:


Reply from 20.20.20.254: Destination host unreachable.

Reply from 20.20.20.254: Destination host unreachable.

Reply from 20.20.20.254: Destination host unreachable.

Reply from 20.20.20.254: Destination host unreachable.


Ping statistics for 11.1.1.1:

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

显然不可以

4.测试外网可不可以访问内网

Router#ping 10.10.10.2


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

显然不可以

文章可能存在很多的问题,希望大家可以帮我指出。


CCNA考试 官方正规报名 仅需1500元
回复 论坛版权

使用道具 举报

芯蕊111 [Lv8 技术精悍] 发表于 2013-5-31 21:27:24 | 显示全部楼层
回复 支持 反对

使用道具 举报

芯蕊111 [Lv8 技术精悍] 发表于 2013-5-31 21:27:31 | 显示全部楼层
回复 支持 反对

使用道具 举报

fucking [Lv8 技术精悍] 发表于 2013-10-9 11:09:10 | 显示全部楼层
路过,学习下,感谢攻城狮论坛
回复 支持 反对

使用道具 举报

芙英 [Lv8 技术精悍] 发表于 2013-10-9 14:08:01 | 显示全部楼层
找到好贴不容易,我顶你了,谢了
回复 支持 反对

使用道具 举报

bestshot [Lv8 技术精悍] 发表于 2013-10-9 14:39:43 | 显示全部楼层
我是来刷分的,嘿嘿
回复 支持 反对

使用道具 举报

Sanitarium [Lv8 技术精悍] 发表于 2013-10-9 15:24:32 | 显示全部楼层
学习了,谢谢分享、、、
回复 支持 反对

使用道具 举报

ericyuenhk0913 [Lv8 技术精悍] 发表于 2013-10-10 10:41:39 | 显示全部楼层
回复 支持 反对

使用道具 举报

cosubbs [Lv8 技术精悍] 发表于 2013-10-10 14:55:18 | 显示全部楼层
路过,支持一下啦
回复 支持 反对

使用道具 举报

kid93c24 [VIP@钻石] 发表于 2013-10-10 16:47:29 | 显示全部楼层
真是 收益 匪浅
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|无图浏览|手机版|网站地图|攻城狮论坛

GMT+8, 2020-4-8 14:36 , Processed in 0.410352 second(s), 22 queries , Gzip On, Memcache On.

Powered by Discuz! X3.2 © 2001-2013 Comsenz Inc.

Designed by ARTERY.cn